[Qt] Mac OS lion(10.7) と Qt 4.8(beta)

2011/09/10

こんにちは。きんくまです。

QtはC++のアプリケーションを作りやすくするフレームワークです。
http://qt.nokia.com/title-jp?set_language=ja&cl=ja

Win / Mac の他にSymbianなどの携帯デバイス向けにも作ることができます。
iOS / Androidはできません。

それで、Qtを試してみたところ、ビルドがうまく行きません。
どうやら、Mac OS lionとQtのバージョンがかみ合っていないようです。
最新版Qt4.7.4ではlionは未サポートなのです。

で、lionに合うQtはベータ版の4.8だそうです。
なので、インストールしてみました。

最初に(私のはOSの言語を英語にしちゃってるので、英語メニューになっとります)
Select > Qt menu > Help > Start updater

それでSDK maintenanceToolが立ち上がります。

ラジオボタンから ‘Package manager’ を選択します。

チェックボックスからQt 4.8.0 beta (Desktop) を選択して、
‘Continue’ ボタンを押します。

SDKがインストールされたら、Qt creatorに戻って、

Select > Qt creator > Preferences > Qt4
さきほどのSDKをマニュアルで使えるように登録します。

個別のプロジェクトの設定で
プルダウンの ‘Qt version’ からさきほどの beta SDKが選べるようになっています。

最後にビルドしてみて、エラーが出なければOKです。


自作iPhoneアプリ 好評発売中!
フォルメモ - シンプルなフォルダつきメモ帳
ジッピー電卓 - 消費税や割引もサクサク計算!

ページトップへ戻る